Paul Galvin's (old) SharePoint space [SharePoint

Just another WordPress.com site

MOSS KPI bug? List Indicator Tied to Document Library With Folders

 

UPDATE 02/29/08: I solved this problem by creating a folder and then assigning a content type to the folder which has the meta data I need for the KPIs.  I described that in a little more detail here.

We have implemented a technical solution where users upload documents to a document library.  An event receiver creates a directory and moves the file to that directory (using a technique similar to what I wrote about here).  We’ve successfully navigated around the potential issues caused by event receivers that rename uploaded files (mainly because users never start their document by clicking on "New" but instead create the docs locally and then upload them).

The meta data for these documents includes a Yes/No site column called "Urgent" and another site column called "Status".  We need to meet a business requirement that shows the percentage of "Urgent" documents whose status is "Pending".

This is usually simple to do and I described something very much like this at the SharePoint Beagle with lots of screen shots if you’re interested.

In a nutshell, I did the following:

  • Create a view on the doc library called "Pending".
  • Configure the view to ignore folder structure.
  • Create a KPI List.
  • Create an indicator in the list that points to the doc lib and that "Pending" view.

This simply does not work.  The KPI shows my target (e.g. five urgent documents) but always shows the actual number of urgent documents as zero.  Paradoxically, if you drill down to the details, it shows the five urgent documents in the list.  I created a very simple scenario with two documents, one in a folder and one not.  Here is the screen shot:

The above screen shot clearly shows there are two documents in the view but the "value" is one.  The "CamlSchema" with blank document Id is in the root folder and the other is in a folder named "84".

It appears to me that even though you specify a view, the KPI doesn’t honor the "show all items without folders" setting and instead, confines itself to the root folder.

If I’m wrong, please drop me a line or leave a comment.

</end>

Subscribe to my blog!

 

Technorati Tags:

Advertisements

One response to “MOSS KPI bug? List Indicator Tied to Document Library With Folders

  1. John February 15, 2008 at 10:09 am

    I\’ve seen before in other situations where you are trying to compare the value of Yes/No fields that the value isn\’t "yes" or "no" but rather 1 or 0.  Check the value of the item in the object model to confirm.  I know with the Advanced Search 1 and 0 works but not yes or no.  See if that works, if it doesn\’t you could always create a Choice field with the values Yes and No.
     
    -John

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: